0

We are experiencing throttled error while publishing.

Some time back around 6 months, we had faced the problem and increased the WindowSize="40" Workers="20" in deployer config file to WindowSize="80" Workers="40".

Now,again we face same problem today. I believe these values are already more.

Shall I increase them further to fix this. I believe increase this values also causes slowness in publishing.

The target is in linux machine and no of cores/processors are 2.

Can any one provide suggestions to fix this permanently. It would be really great if some one provide exact configuration for this.

0
4

Please check the location where the rendered packages are being generated on Publishers. If there are a lot of packages present in the folder (because of failed publish transactions which do not get cleaned up), the publishers sometimes do not take any more packages considering they have to process these packages first. Please clean up the folder and it should resolve. Please check the deployer incoming folder for the same as well. This is one of the reasons when the transaction enters Throttled state.

Also, increasing # of threads on deployers is not always the solution. You might need to adjust the render thread count in content manager config on the publisher servers as well. Refer this question (Rendering Thread Count - Publishing)

3

when the throttling happens, do you see any errors/warning in the deployer logs? It would be interesting to understand the exact reason for the throttling. In principle, I think that the windowSize and Workers that you currently have is already too high, so increasing these will not avoid the throttling status and will probably introduce other behaviors (like locks on the broker database due to the high number of workers writing at the same time into the database).

As mentioned on the previous post, it may help to clean up some folders. In addition to clean up the temp folder that the Publisher uses (by default, c:\temp > as defined in the Snap-in under Publisher settings) as well as the transactions folder that the Transport Service. Although i dont think these actions will really impact much the throttling - it is always good to do some cleanup of these folders.

Probably, the threads configured in the Publisher side are quite high, so the transport is sending a lot of load at the same time to the deployer. So, can you share the number of threads for rendering and deploying on the Snap-in, as well as, the number of cores on the Publisher server.

Moreover, throttling might happen because the deployer needs longer to write content: large packages to deploy and/or no database maintenance tasks on the broker.

2
  • Thanks for the hint. I have cleaered the folders under c\temp now. Number of threads as per snap in are Deploying: 8 Rendering 8 cores in CME server 4 getting error as Destination in Throtling mode. Can you check if it can sorted. – Patan Apr 3 '15 at 11:21
  • @Patan - I have one question for you: after which state in publishing, processes are going to throttling state? Did you clear incoming folder on deployer? If there are lots of files in incoming folder even though those are not being processed by deployer, deployer still thinks that those files are part of the queue and put the status as throttled. – Hiren Kaku Apr 3 '15 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.