0

I am getting a timed out error while using template builder. It was working fine until last week.

System.Net.WebException: The operation has timed out at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request) at System.Web.Services.Protocols.HttpWebClientProtocol.GetWebResponse(WebRequest request) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Tridion.ContentManager.Templating.CompoundTemplates.DomainModel.Proxy.CompoundTemplateWebService.StartDebuggingWithItemUri(String compoundTemplateId, String compoundTemplateXml, String itemId, Boolean includeSystemLog, TraceEventType logLevel) at Tridion.ContentManager.Templating.CompoundTemplates.DomainModel.DebugObject.Start(Template template, Object debugItem, LoggingOptions loggingOptions)

Tried accessing the templating web service from browser and it is accessible.

I am using template builder 7.1 and Tridion 2013 SP1.

6
  • Are you able to browse Tridion Without any issue? Jun 8, 2015 at 9:26
  • Yes, even publishing is working. All ok from CMS side. Jun 8, 2015 at 9:27
  • How much time does it take roughly getting the timeout? Is it a Sitemap or Navigation type page? Jun 8, 2015 at 9:48
  • Check which URL it is connecting to, by clicking File | Log on As... Perhaps it is using a domain that is no longer valid, or connecting to a different machine than you think. Jun 8, 2015 at 9:49
  • around 2 mins..... Jun 8, 2015 at 9:52

1 Answer 1

1

I haven't ever seen such a timeout issue, but knowing that the Template Builder connects to the CMS server there could be a couple of issues there.

First thing I would consider is to check if there are no firewall issues that might have been placed/changed since the time it was working.

Next check if you can open the items (Template, TBBs and Component/Page) which are used in the Template Builder directly in the CMS?

And then you might want to go the basic route, try rebooting the CMS server, making sure there are no hanging services etc.

Another thing you might want to do in parallel is to check if your database server is properly maintained. Has the transaction log been backed up and truncated, and have the indexes been rebuild on a regular maintenance schedule?

3
  • The last option I tried was rebooting the server....and it is working now :) Jun 9, 2015 at 9:43
  • Rebooting the server is a workaround not a solution :) Without the underlying cause being removed this problem may return at any time... Jun 10, 2015 at 6:26
  • incidentally the CMS license was expired on same day. The license was replaced, but template builder issue continued until server restart Jun 10, 2015 at 7:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.