2

I'm using DXA 1.1. I added a new PT & published a page that uses the new PT, but I get the error listed below. What am I missing? I published the settings. Added a view for the new PT.

Localization [100 ('English')] does not contain includes for Page Type '99999'. Check that the Publish Settings page is published and the application cache is up to date.

2

My settings were correct. I checked this file: http://localhost/system/mappings/includes.json, which is where the include info comes from. My page was not on the file on my localhost but was on the dev server. Another developer suggested I delete the localization directory called 100 from my file system. I did that, republished & my new PT worked worked. DXA bug maybe?

|improve this answer|||||
  • Did you hit the refresh URL /admin/refresh after republishing the settings? This will usually re-generate the JSON config files on the FS if the configuration has been changed (=republished). But there could be a bug indeed... – Will Price Sep 2 '15 at 6:58
  • Sounds like a caching issue indeed, since when you deleted the directory, you forcefully cleared the cache to disk. Requesting the /admin/refresh URL as Will suggested should have had the same outcome. You always have to clear the cache after you republished the Publish Settings page, and preferably that is done by calling /admin/refresh – Bart Koopman Sep 2 '15 at 7:42
  • ok, I thought I did that. but ill be sure to try next time – Mr Smith Sep 2 '15 at 13:04
  • 1
    @MrSmith if you find a reproducible scenario let us know, if there is a bug we need to fix it for sure – Bart Koopman Sep 2 '15 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.