4

I have installed DXA 1.4 .NET on my SDL Web 8 System. When I hit application, I get the following message:

Item '/system/config/_all.json' not found for Localization '6'

Site.log error

ERROR - Item '/system/config/_all.json' not found for Localization '6'
Sdl.Web.Common.DxaItemNotFoundException: Item '/system/config/_all.json' not found for Localization '6'
   at Sdl.Web.Tridion.Statics.BinaryFileManager.GetCachedFile(String urlPath, Localization localization) in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Tridion\Statics\BinaryFileManager.cs:line 89
   at Sdl.Web.Tridion.Mapping.DefaultProvider.GetStaticContentItem(String urlPath, Localization localization) in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Tridion\Mapping\DefaultProvider.cs:line 151
   at Sdl.Web.Common.Configuration.Localization.LoadStaticContentItem[T](String relativeUrl, T& deserializedObject) in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Common\Configuration\Localization.cs:line 367
   at Sdl.Web.Common.Configuration.Localization.Load() in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Common\Configuration\Localization.cs:line 427
   at Sdl.Web.Common.Configuration.Localization.EnsureInitialized() in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Common\Configuration\Localization.cs:line 149
   at Sdl.Web.Tridion.CdApiLocalizationResolver.ResolveLocalization(Uri url) in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Tridion\CdApiLocalizationResolver.cs:line 96
   at Sdl.Web.Mvc.Configuration.WebRequestContext.get_Localization() in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Mvc\Configuration\WebRequestContext.cs:line 23
   at Sdl.Web.Mvc.Statics.StaticContentModule.BeginRequest(Object sender, EventArgs e) in c:\Jenkins\workspace\DXA Dev CI Web App .NET\Sdl.Web.Mvc\Statics\StaticContentModule.cs:line 51
2016-06-24 11:37:30,348 [10] WARN  - Item '/system/config/_all.json' not found for Localization '6'. Sending HTTP 404 (Not Found) response.
2016-06-24 11:37:30,348 [10] DEBUG - StaticContentModule.BeginRequest() exit. Duration: 223 ms.

i have published all pages as mentioned in sdl document and check my application folder system/config _all.json is there and all pages in borker but still facing the issue while rendering home page

http://docs.sdl.com/LiveContent/content/en-US/SDL%20DXA-v4/GUID-626FDF93-2D0B-4B3B-9CB1-9A0D7402FD82

i have already referred below url but did not find any solution

_all.json not found

Error on accessing website DXA 1.4

> PS C:\Windows\system32> Get-TtmWebsite
> 
> 
> BaseUrls             : {http://localhost:90} CdEnvironmentId      :
> SampleCD EnvironmentPurpose   : Staging CdEnvironment        : 
> ScopedRepositoryKeys : {DxaSiteType, DxaExampleSite} Id               
> : Website2 ExtensionProperties  : {}
> 
> BaseUrls             : {http://localhost:86} CdEnvironmentId      :
> SampleCD EnvironmentPurpose   : Staging CdEnvironment        : 
> ScopedRepositoryKeys : {} Id                   : visitorsweb
> ExtensionProperties  : {}

Kindly let me know if i missed something

  • Where did you check the presence of _all.json exactly? It should be in folder BinaryData\6\system\config within you DXA Web App root. But the exception implies is not. It should be retrieved from the CD Content Store (broker) in that case, though... – Rick Pannekoek Jun 24 '16 at 6:49
  • 1
    Check the BINARY_VARIANTS table in your CD Content Store to verify that _all.json' is indeed published in Publication 6. – Rick Pannekoek Jun 24 '16 at 6:53
  • @RickPannekoek its in multiple folders of site website\system\ _all.json , resources\ _all.json, config\ _all.json, mappings\ _all.json and in broker BINARY_VARIANTS table publication 6 VARIANT_ID ="statics-bootstrap" PATH and URL = /system/_all.json all other folder mapping is available in broker – meyank Jun 24 '16 at 7:40
  • Weird. We have observed similar spurious errors on SDL Web 8 systems with UGC cartridge enabled. Do you have that on your system? If so, try disabling it. – Rick Pannekoek Jun 24 '16 at 7:47
  • 1
    Changing media path to other folder can cause this issue as the BinaryData folder meant to be acting as cache and your all.json has the info about it, if that's getting read from diff file you probably need to find a way to tell your DXA application to check for settings (all.json) from your specified place. Also check if you see all.json at the place you are storing your media? – Vikas Kumar Oct 3 '16 at 22:11
-2

Hi the issue is by default DXA searches binary files inside BinaryData/5/, so you have to set this path in Deployer storage.config to publish binaries inside BinaryData/5. Here 5 is your publication ID. For instant solution create the binarydata/5 folder at your root application and paste system folder inside that folder so you path will be eg. Webapp/BinaryData/5/system.

  • 3
    As a matter of fact, you have to configure your deployer to store everything (pages, DCPs and binaries) in the CD Content Store. See the DXA Docs: docs.sdl.com/LiveContent/content/en-US/SDL%20DXA-v4/… – Rick Pannekoek Jun 27 '16 at 17:26
  • You got me confused by saying that the files were present in the BinaryData directory (which is DXA's filesystem cache of binaries stored in the CD Content Store)... – Rick Pannekoek Jun 27 '16 at 17:29
  • i have configured deployer to publish (pages,DCP) in CD Content Store , binarys to file system and i have not mentioned that the binaries are present inside BinaryData in my case its present inside website\system\_all.json as mentioned above. here website is my application root folder . – meyank Jun 28 '16 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.