3

Bit of a weird issue on my newly updated Tridion 2013 SP1 HR1 environment (from 2011 SP1 HR2). This happens across Dev, Qa, Uat and Live CMEs.

Opening a page gives "the item was updated to reflect the current schema". When clicking save and close I get the "Are you sure you want to leave this page?" as if I had unsaved changes but I haven't.

Once the item has saved, clicking the publish button (ribbon or context menu) has no effect.

I see the following log message in the Chrome Developer tools console:

Executing command "Publish"

But the publishing window does not open. Refreshing the browser allows me to publish until I go through the above steps again.

Chrome 46 + Firefox. I couldn't see hotfix relating to this.

Tried clearing cache and different browsers.

Update: A few things I've tried based on suggestions from MVPs

  • Clear cache
  • Disable GUI extensions
  • Checked the metadata schema of the page was not changed.
  • Checked any embedded schemas used on the metadata schema have not changed.

Any ideas?

  • What happens when you try and preview the page? – Shiva Nov 3 '15 at 14:03
  • The pop up opens and I see DD4T XML There is a 400 bad request to tridion-cme-live.client.co.uk/WebUI/Editors/CME/Views/Popups/… Failed to load resource: the server responded with a status of 400 (Bad Request) Which looks like a malformed path anyway. The DD4T XML then loads (I am still trying to get DD4T PagePreview to work as a seperate issue) – Rob Stevenson-Leggett Nov 3 '15 at 14:09
  • Is the environment a full upgrade or is it a fresh install of 2013 with an upgraded 2011 database? Just wondering if there are old files floating around from the 2011 install that haven't upgraded properly? If that's the case, it might be a good idea to flush the Tridion cache by upping the modification value in the system.config. That probably wont help if it's a clean install of 2013 though... – Mike Percival Nov 3 '15 at 14:09
  • Fresh install, updated database. – Rob Stevenson-Leggett Nov 3 '15 at 14:10
  • Have you tried editing something in a page and try to publish? I have noticed some issues with 2011 upgraded systems, in the past. I am assuming that the publication targets created, pop-up blockers enabled and we do not have any custom resolver. – Shiva Nov 3 '15 at 14:36
4

Thanks to Mike Percival (World #1 Tridion Expert) for putting me on the right track.

This appeared to be caused by the Page/Structure Group Metadata Schema having an Embedded Schema with a mandatory field selected from a Category which contained no items with no default value. Even though the Embedded Schema field was not mandatory on the parent Schema this still seemed to be the root cause.

Making the first field non-mandatory on the Embedded Schema and saving fixes the behaviour.

  • Glad I could help with it! – Mike Percival Nov 3 '15 at 15:40
1

I think Rob/Mike analysis is correct in their answer; however, if you want to keep the existing mandatory fields for the embedded schema, ensure the mandatory field selected from a Category list type is set to use tree.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.