We have an Authorization error when running the Add-TtmCdTopologyType command. We've tried the suggestions in this question but still no luck. We're running with a Domain account that is also in the Discovery Service Ambient config.

I don't understand how the authorization part works between the Powershell command and ADF config of the Discovery service, and which users it is using, etc. Also, how to get any logging of it (our Discovery service log had no entries, even in Debug mode).

Our error message:

PS C:\Users\mts_svc> Add-TtmCdTopologyType -Id Site

cmdlet Add-TtmCdTopologyType at command pipeline position 1
Supply values for the following parameters:
(Type !? for Help.)
Name: Site
EnvironmentPurposes[0]: Preview
EnvironmentPurposes[1]: Live
EnvironmentPurposes[2]: Test
EnvironmentPurposes[3]: Dev
Add-TtmCdTopologyType : Authorization has been denied for this request.
At line:1 char:1
+ Add-TtmCdTopologyType -Id Site
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (Tridion.Topolog...logyTypeCommand:AddCdTopologyTypeCommand) [Add-TtmCdTop
   ologyType], DataServiceException
    + FullyQualifiedErrorId : Tridion.TopologyManager.Automation.AddCdTopologyTypeCommand

Our Ambient config here https://gist.github.com/rcurlette/004090c2d6b9731e9f5def57bb3ee8fd

  • Adding of topology type does not require communication with Discovery service. Your powershell should be ran by a user who is in Topology Manager Administrators group in windows. (if you have custom groups for Topology Manager please check which one corresponds to administrators group in topology manager web.config) Apr 13, 2016 at 17:23

2 Answers 2


Adding a CD Topology Type in Topology Manager doesn't result in any communication with CD or CM, so the Authorization error is coming from Topology Manager itself.

Only users in the Windows Group "SDL Topology Manager Administrators" are allowed to change things in Topology Manager. By default, this includes all Windows Administrators, but the catch here is that you also have to run the PowerShell console "as Administrator" for Windows to admit you are in that group. :-)

  • We also had to uninstall and re-install Web 8...not sure exactly why, but it seemed to do the trick. Also, It might be noted that it might help others in the future to know in the ambient conf of the Discover service there are users and also security is enabled by default. In my dev environment I set the security to false...
    – robrtc
    Apr 14, 2016 at 9:41
  • Fortunately, in my case, it was enough to add my user to the Topology Administrators group (my user was in the local Administrators group) and reboot the system
    – DanielGLB
    Oct 1, 2016 at 8:57
  • Adding my user to the SDL Topology Manager Administrators group worked a treat for me. However, I also had to log off the server, log on again and run PowerShell as Administrator to get this to work. Jun 18, 2018 at 9:48

Add the user that you would be using for creating the Topology type via powershell command , to the Topology Administrators group and reboot the system

Add-TtmCdTopologyType -Id SampleTopologyType -Name StagingOnlyType -EnvironmentPurposes "Staging"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.