I'm trying to add a Topology Manager Mapping for our publication to our live environment. Yet when I run Add-TtmMapping I get the following error:

PS C:\Windows\system32> Add-TtmMapping -publicationid tcm:0-5-1 -webapplicationid IntranetLive_RootWebApp
Add-TtmMapping : Item of type 'MappingData' can not be saved. Unable to connect to 'net.tcp://localhost:2660' using authentication type 'Windows'. Access is denied for the user TRDWCMDEV\MTSUser.

What is the cause of this? I already added the user to the Topology Manager Admin group. MTSUser is the user that has been used to install Web 8.

(I get this error too when using any of the Remove-Ttm* cmdlets)

1 Answer 1


According to the error message, TRDWCMDEV\MTSUser does not have access to your Content Manager system.

  • Oh, so I should add him as a user? Right, I'll check that. Thanks Jul 14, 2016 at 7:25
  • Yes, preferably a sysadmin user. A bit of background: for some operations, Topology Manager will communicate with Content Manager (through the Core Service). It uses the Core Service URL and credentials specified in your CmEnvironment entity (in Topology Manager). The credentials should be of an existing, enabled User account (with sysadmin privileges). Jul 14, 2016 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.