6

Today SDL Web8.5 installed in new server. I try open CME url first time and got this error "Because SDL Web could not connect to the notification system, it cannot receive push notifications.". Let me know any configuration missing....

enter image description here

When I open CME got this error: One or more errors occurred.Unexpectedcharacter encountered while parsing value: <. Path '', line 0, position 0. Component: NotificationHub Errorcode: 0 User: NT AUTHORITY\NETWORK SERVICE StackTrace Information Details: at Newtonsoft.Json.JsonTextReader.ParseValue() at Newtonsoft.Json.JsonTextReader.Read() at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.ReadForType(JsonReader reader, JsonContract contract, Boolean hasConverter) at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.Deserialize(JsonReader reader, Type objectType, Boolean checkAdditionalContent) at Newtonsoft.Json.JsonSerializer.DeserializeInternal(JsonReader reader, Type objectType) at Newtonsoft.Json.JsonConvert.DeserializeObject(String value, Type type, JsonSerializerSettings settings) at Newtonsoft.Json.JsonConvert.DeserializeObject[T](String value, JsonSerializerSettings settings) at Microsoft.AspNet.SignalR.Client.Transports.TransportHelper.b__1(String raw) at Microsoft.AspNet.SignalR.TaskAsyncHelper.TaskRunners2.<>c__DisplayClass42.b__41(Task1 t) at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken) at Sdl.SignalR.SignalRMessageBus.SignalRMessageBus.Initialize() at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, StackCrawlMark& stackMark) at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) at System.Activator.CreateInstance(Type type, Object[] args) at Sdl.SignalR.Backplane.Common.HubLoader.CreateMessageBus(String assembly, String scaleoutConfigurationType, String scaleoutMessageBusType, Boolean patchOnReceived, Object[] backplaneConfigurationParameters) at Sdl.SignalR.Backplane.Common.HubLoader.Load(IAppBuilder app, String assembly, String scaleoutConfigurationType, String scaleoutMessageBusType, String hubAssemblyName, Boolean patchOnReceived, Object[] backplaneConfigurationParameters) at Tridion.Web.NotificationHub.Startup.Configuration(IAppBuilder app)

Looking recommendation and solution for this issue.

  • 1
    My guess is that you have a firewall policy that is blocking the port on the which the notifications are communicated. – Nickoli Roussakov Mar 16 '17 at 0:59
  • it`s working fine in three development server and one SIT server. I check tomorrow morning once second again!!! – Sudhakar Rao Mar 16 '17 at 7:33
  • When I open CME got this error: – Sudhakar Rao Mar 16 '17 at 17:34
  • 1
    you should mention this is a server with Site Minder protection and none of the other servers have it :) – Warner Soditus Mar 16 '17 at 22:15
  • It's indeed possible that Site Minder is interfering and returning a different response. You should be able to see that using a network monitoring tool such as Wireshark. – Peter Kjaer Mar 17 '17 at 9:43
3

This issue occurs SSO enabled CME, To resolve by adjusting the following config values.

[Install Path]SDL Web\hubs\backplaneHub\Web.config

<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <tridionConfigSections>
    <sections>
      <clear />
      <add filePath="..\..\config\Tridion.ContentManager.config" />
    </sections>
  </tridionConfigSections>
  <system.web>
    <httpRuntime targetFramework="4.5.2" />
  </system.web>
  <system.webServer>
    <modules>
        <remove name="OpenAmModule64" />
        <remove name="SsoAgentHttpModule" />
    </modules>
  </system.webServer>
  <system.net>
    <settings>
      <servicePointManager
          checkCertificateName="false"
          checkCertificateRevocationList="false" />
    </settings>
  </system.net>
</configuration>

Note: Also, ensure this below URL response is getting 200 response code with javascript output, may be this URL throw 500 error due to SSO enabled.

https://CMS-URL/hubs/notificationHub/signalR/hubs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.