2

When serving Web site by using Tomcat, and using Broker legacy API (in-process), is there any recommended version of Tomcat?

On RESTful API, client-side API requires only Java 8.0. This is described in following manual

Prerequisites for client-side APIs and Web application extensions

Are following conditions applied for legacy API (in-process) same as client of RESTful API?

  • Requires Java 8.0
  • Any version of Tomcat is OK

Regards,

| improve this question | | | | |
3

Tomcat version: Looking at the Content Delivery presentation environment Web application server support history page in the online docs, it appears that only Apache Tomcat 7.0 is supported for SDL Web 8.5 and, even then, it must be v7.0.47 or later.

Java version: From the Content Delivery Java and .NET support history page, only Java 8 is supported.

| improve this answer | | | | |
  • I asked about this issue to SDL, the answer is 'Content Delivery presentation environment Web application server support history' is available for legacy API (in-process) too. – Hirokazu Shikata Dec 14 '17 at 6:53
  • Excellent, so it looks like Tomcat 7 (v7.0.47 and above) is the only supported version. Thanks for confirming. – Jonathan Williams Dec 14 '17 at 10:02
  • Tomcat 8.5.6 is also supported on Web 8.5 according to the document. – Hirokazu Shikata Dec 22 '17 at 4:33
  • Ah, yes, you’re correct. – Jonathan Williams Dec 22 '17 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.