-1

I am using Web 8.5. When I try to publish any Pages, I am getting below error:

Transport service failed to transport.

<Summary state="Failed" referenceId="tcm:0-12-66560"><Error>Unable to read transport instructions.Deployer capability not specified in: http://localhost:8082/discovery.svc</Error><Processing><Context topic="Content Delivery"><IsRollbackOnFailure /></Context></Processing><Target /></Summary>
2
  • Sorry but ir is very unclear what you are asking. Can you add informatrion to the question. if there is any question? Dec 27, 2017 at 19:40
  • You should definitely try to make this question clearer. In the meantime, you could start with checking the capabilities that you have registered with the discovery service. The error says you don't have the deployer capability registered. Dec 27, 2017 at 20:27

1 Answer 1

6

When you go to http://localhost:8082/discovery.svc/Environment/DeployerCapability you should see details of your Deployer Capability, as shown below

<entry 
xmlns:metadata="http://docs.oasis-open.org/odata/ns/metadata" 
xmlns:data="http://docs.oasis-open.org/odata/ns/data" 
xmlns="http://www.w3.org/2005/Atom" metadata:context="http://localhost:8082/discovery.svc/$metadata#Environment/DeployerCapability" xml:base="http://localhost:8082/discovery.svc">
<id>http://localhost:8082/discovery.svc/DeployerCapabilities('DefaultDeployer')</id>
<title></title>
<summary></summary>
<updated>2017-12-27T22:12:51.194Z</updated>
<author>
    <name>SDL OData v4 framework</name>
</author>
<link rel="edit" title="DeployerCapability" href="DeployerCapabilities('DefaultDeployer')"></link>
<link rel="http://docs.oasis-open.org/odata/ns/related/Environment" type="application/atom+xml;type=entry" title="Environment" href="DeployerCapabilities('DefaultDeployer')/Environment"></link>
<link rel="http://docs.oasis-open.org/odata/ns/relatedlinks/Environment" type="application/xml" title="Environment" href="DeployerCapabilities('DefaultDeployer')/Environment/$ref"></link>
<category scheme="http://docs.oasis-open.org/odata/ns/scheme" term="#Tridion.WebDelivery.Platform.DeployerCapability"></category>
<content type="application/xml">
    <metadata:properties>
        <data:id>DefaultDeployer</data:id>
        <data:LastUpdateTime metadata:type="Int64">1514412431953</data:LastUpdateTime>
        <data:strategy>DEFAULT</data:strategy>
        <data:URI>http://192.168.0.112:8084/httpupload</data:URI>
        <data:URIs metadata:type="#Collection(Tridion.WebDelivery.Platform.DestinationURL)"></data:URIs>
        <data:ExtensionProperties metadata:type="#Collection(Tridion.WebDelivery.Platform.DeployerKeyValuePair)">
            <metadata:element>
                <data:Key>undo.enabled</data:Key>
                <data:Value>false</data:Value>
            </metadata:element>
            <metadata:element>
                <data:Key>encoding</data:Key>
                <data:Value>UTF-8</data:Value>
            </metadata:element>
        </data:ExtensionProperties>
    </metadata:properties>
</content>
</entry>

If you instead see the following, then your deployer is either not setup correctly or not registered with the discovery service

<metadata:error xmlns:metadata="http://docs.oasis-open.org/odata/ns/metadata">
<metadata:code>3500</metadata:code>
<metadata:message>
Entity not found for this query: http://localhost:8082/discovery.svc/Environment/DeployerCapability
</metadata:message>
</metadata:error>

To quickly check the Deployer is running, you could try navigating to the default URL (assuming no changes): http://localhost:8084/httpupload where you should see the response

SDL Tridion HTTP Upload and Responder Servlet

Assuming this is working, it is time to check the capability is setup correctly in the configurations (review the log files) and that the capability has been registered with the Discovery service either with The Discovery Registration Tool or using the auto-register flag during install

Once you've tried some of these things, please add more detail to the question so we can help you more

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.