I have installed the micro-services successfully and they are up and running. But, when I run the registration jar file to register all the services with the discovery service, I get an error saying "Not able to find builder for capability: TokenServiceCapability"

The command I am running is java -jar discovery-registration.jar update from the discovery config folder as mentioned in the SDL docs.

Here is a screenshot of the error enter image description here

There is nothing in the logs too.

Also, this is what I have in the cd_storage_conf.xml file in the discovery/config folder

<ConfigRepository CacheEnabled="true" CacheExpirationDuration="600" ClientId="registration" ClientSecret="encrypted:HzfQh9wYwAKShDxCm4DnnBnysAz9PtbDMFXMbPszSVY=" ConnectionTimeout="40000" ServiceMonitorPollDuration="10" ServiceUri="http://localhost:8082/discovery.svc" TokenServiceUrl="http://localhost:8082/token.svc">
            <Role Name="TokenServiceCapability" Url="http://localhost:8082/token.svc"/>
            <Role Name="WebCapability"/>

The microservices are on the same server as the CM, that is why I am using localhost there.

1 Answer 1


The issue was I had Java 9 installed and Web 8.5 only supports Java 8. Just removed Java 9 and installed Java 8 and it worked fine.

  • Don't forget to mark your answer as correct. Commented Feb 2, 2018 at 8:44
  • Yes. It seems I can accept it only after 2 days. Commented Feb 2, 2018 at 12:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.