0

We have added two new fields in embedded schema.We could see the changes in the respective components, however when you publish the page the newly added fields are not getting published.

Can anyone please help to identify what could be going wrong ?

Note: Everything works fine in lower environments, but when moved to staging its not working.

UPDATE : We are using DXA 1.5, verified the build and made sure that code changes are there in the higher environment. And published the 'Publish Settings' file as well.

UPDATE 2 : I have tried pointing my local to staging environment, and i could see that its working fine. So i believe its getting published properly and there is no issue in code as well. May something specific to environment, but i dont see any issues in logs as well.

  • Provide more information about your implementation. Are you using DXA? If yes, did you publish the Publish Settings Page after updating schema on the higher environment? – Sayantan Basu Aug 21 at 18:51
  • Thanks for your response, i have updated my question with the details – user2869 Aug 21 at 19:52
  • can you confirm it's actually not published (check in the broker database), or if the DXA website is still using some cached version). If the data is published to the broker DB, then there must be an issue with the DXA webapp. If it isn't published, then there's a problem in the publisher side (templates, deployer,...) – Harald Hoffelinck Aug 22 at 17:06
  • @HaraldHoffelinck thank you for your response, i have tried pointing my local to staging enviornment, and i could see that its working fine. So i believe its getting published properly and there is no issue in code as well. May be something specific to enviornment. However i dont see anything wrong in logs as well. – user2869 Aug 22 at 20:10
0

Based on your updates, it looks like the files have been deployed to the broker without any issues. If the code works from your local connecting to the staging environment broker, you code is also working with the newly modified models and the views in the web application.

It definitely looks like an issue with the version of code deployed on the server. Can you wipe out the DXA root application on the server and deploy your entire web application code to the environment?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.