10

I have successfully created an export package from a Tridion installation using Content Porter 2009 SP2 (v3.2.0.349).

Taking this exported package and attempting to import it into a clean installation (exactly the same version), fails with the below error message:

10/11/2013 1:25:36 PM [Information] Resolving item mappings
10/11/2013 1:25:36 PM [Information] Mappings resolving started
10/11/2013 1:25:37 PM [Information] Mappings resolving finished
10/11/2013 1:25:37 PM [Information] Discovering potential problems
10/11/2013 1:25:37 PM [Information] Problems discovery started
10/11/2013 1:26:18 PM [Information] Problems discovery finished
10/11/2013 1:26:18 PM [Information] Synchronizing content against Schemas
10/11/2013 1:26:18 PM [Information] Content synchronization started
10/11/2013 1:26:24 PM [Information] Content synchronization finished
10/11/2013 1:26:41 PM [Information] Import started
10/11/2013 1:26:41 PM [Information] Importing System Administration items
10/11/2013 1:26:44 PM [Information] Importing items into '020 Global Content EN (Master)' Publication
10/11/2013 1:26:44 PM [Information] Importing items into '020 Global Content EN (Master)' Publication started at 14:26:44
10/11/2013 1:36:34 PM [Error] <?xml version="1.0"?>
<tcm:Error xmlns:tcm="http://www.tridion.com/ContentManager/5.0" ErrorCode="8004E007" Category="7" Source="Kernel" Severity="1"><tcm:Line ErrorCode="8004E007" Cause="true"><![CDATA[Automation error
You made a method call on a COM  component that has a transaction that has already committed or aborted. ]]></tcm:Line><tcm:Details><tcm:CallStack><tcm:Location>Request.GetItem</tcm:Location><tcm:Location>XMLResponder.Request</tcm:Location></tcm:CallStack></tcm:Details></tcm:Error>

10/11/2013 1:36:37 PM [Information] Import failed
=======
Start time: 2013-10-11 14:26:25
End time: 2013-10-11 14:36:37

All changes made during import process were rolled back
10/11/2013 1:36:37 PM [Error] Transactional import failed. No changes will be commited.
10/11/2013 1:36:37 PM [Information] Import completed

The package is at level 020, and depends on 010 and 000, both of which have successfully exported from the source installation and imported into the destination installation.

I'm not aware of anything funky with the 020 level, but was not involved in the creation of the system. Has anyone else had this error before, or have any suggestions on how to resolve it?

P.S. Terrible about the misspelling of 'committed' in the second to last line of the log.

END OF LINE

  • 1
    Have you tried importing first the stuff into 000, then into 010 and finally into 020 (so as separate imports) ? – Raimond Oct 11 '13 at 20:42
  • That's the only way I've tried it Raimond. Exported 000 from source, imported 000 into target = success. Next export 010 from source, import 010 into same target = success. Finally export 020 from source (success, no warnings/errors), import into target = fail with above details. – Mark Sizer Oct 12 '13 at 18:42
6

The simplest thing to try is doing a non-transactional import. The message seems to be indicating that the problem is to do with the transaction.

If you really need to do transactional imports (we managed for years without them), then I'd suggest making smaller imports until you get down to a scope that succeeds.

In any case, trying to identify the problematic object is important. You may well find that it's an item that won't save properly via the GUI or API, and that fixing a problem with the item allows the import to succeed.

As for the spelling capabilities of the development team, I'd suggest that this might be the wrong criterion on which to judge them. :-)

| improve this answer | |
  • That's some great advice there Dominic, thanks. I'll give it a try and report back if I make any progress. – Mark Sizer Oct 14 '13 at 8:44
  • 1
    I can confirm that doing a non-transactional import does indeed allow me to work-around the problem. I'd like to understand the cause of the problem though, so if I can find time I'll take your second point and try granular imports to try and locate the problem object. Watch this space. If you're interested in knowing the outcome. – Mark Sizer Oct 15 '13 at 14:34
  • Once the non-transactional import has succeeded once, it seems that reimporting the same publication as a transactional import then also succeeds. If I delete the DB and try again, then setting the 'Synchronise content against schema' to true also resolves the problem. I didn't manage to identify the exact object that was causing the problem, but I'm out of time on this one and have to move onto other tasks. Thanks for the guidance though Dominic! – Mark Sizer Oct 21 '13 at 9:14
  • Glad to hear you managed to make some more progress. Sounds like some of your components don't match the schema. – Dominic Cronin Oct 21 '13 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.