5

I am getting a strange issue in publishing phase. Publishing queue shows success message but only a few pages are not actually copied to my IIS directory. lots of other pages published in the same transaction works well.

I'm using the core service to perform the publishing using the following code:

client.Publish( new[] { page.Attribute( "ID" ).Value }, pubData, new[] { publishingTargetID }, PublishPriority.High, null );
6

If you're publishing pages that are contained in sub structure groups you may need to uncheck the 'republish only' checkbox in the publish dialog, this is a safety mechanism in the cms to ensure that users don't accidentally publish new content to the cms.

You can also view the 'see items to publish' to confirm which content will be published.

As you're doing this via the core service, please check my post here

The main point is this line:

resolveInstruction.Purpose = parameters.Republish ? ResolvePurpose.RePublish : ResolvePurpose.Publish;
| improve this answer | |
  • Can i uncheck this box programmatically? I using core service to get list of all pages and sending them to publishing queue in a loop. – Ali Dec 18 '13 at 3:49
  • Yes, might be worth posting your code to see how you're doing the publishing – johnwinter Dec 18 '13 at 4:54
  • 1
    client.Publish( new[] { page.Attribute( "ID" ).Value }, pubData, new[] { publishingTargetID }, PublishPriority.High, null ); This code is in loop. – Ali Dec 18 '13 at 5:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.