6

I have setup SDL Tridion 2013 which is running in port 80 for Intranet and port 443 for Internet and have the DNS binding.

Tridion CME is running properly and loading properly in CMS server if I have “Windows Authentication” enabled in IIS for site “SDL Tridion”.

I have bind the SDL Tridion website with port 443 to access through internet with ASP.NET Impersonation and Basic Authentication. I am getting error

“/WebUI/Core/Services/Communicator.svc/Invoke failed to execute. STATUS (500): System.ServiceModel.ServiceActivationException” and “/WebUI/Core/Services/Communicator.svc/Invoke failed to execute. STATUS (404): Not Found” and CME is not loading properly in both Intranet and Internet.

I have changed the following, still doesn’t help anything.

  1. Changed the client browser settings as explained in the SDL Live Content login.
  2. I have enabled the below in web.config file under web\webui\webroot
<serviceHostingEnvironment aspNetCompatibilityEnabled="true" multipleSiteBindingsEnabled="true">
<!-- The attribute "multipleSiteBindingsEnabled" was introduced in .net 4 and removes the need of http module: Tridion.Web.ServiceModel.HttpSvcPortFunneler -->
<!-- For https protocol and/or multiport configuration, uncomment this. 
     There should be a <add /> entry for each unique combination of protocol and hostname that is configured in IIS Bindings. -->
    <baseAddressPrefixFilters>
        <add prefix="http://servername:80"/>
        <add prefix="https://DNS Name"/>
    </baseAddressPrefixFilters>         
</serviceHostingEnvironment>*
  1. I have added the multiple site binding enabled as true as below in web.config file under *webservices*

  2. I have added the below keys in regedit:

HKEY_LOCAL_MACHINE\SYSTEM\CURRENT CONTROL SET\CONTROL\LSA\NEW\DWORD DisableLoopbackCheck—VALUE AS “1”

HKEY_LOCAL_MACHINE\SYSTEM\CURRENT CONTROL SET\CONTROL\LSA\MSV1_0\NEW\MULTI STRING VALUE\VALUE NAME AS “BackConnectionHostNames” AND VALUE DATA AS “DNS ENTRY OF THE SDL TRIDION SITE”

Any help/suggestion will be helpful.

  • if its resolved please share the resolution. – Raj Kumar Mar 3 '14 at 4:59
5

along with what Ram mentioned above. and from your question it seems you already set the DisableLoopbackCheck entry in registry.

did you restart computer after updating registry?

Please refer following links

tridion-vm-multiple-host-headers

installation-issue-with-sdl-tridion-2013-cme-not-loading-all-items-properly

Please check whether extended Protection of iiS->Windows-auth is off, In some scenario its helpful.

enter image description here

  • Yes Raj Kumar. I have done the changes and did the restart also. But doesn't help still.... – Jey Mar 3 '14 at 8:32
  • somebody on one SO post told to suffix :443 after domain, prefix="DNS Name:443, you can give it a try. – Raj Kumar Mar 3 '14 at 17:40
  • did you see any error change? after trying different solution from this post. – Raj Kumar Mar 5 '14 at 12:20
  • updated my answer, please check. – Raj Kumar Mar 8 '14 at 8:39
3
+25

The following error that you are seeing:

STATUS (500): System.ServiceModel.ServiceActivationException

...is the same as that reported by Mihai his ServiceActivationException after Installing Tridion 2011 blog post.

You could try updating the list of authentication providers within the MetaBase.xml file.


I don't know the full workings of why this would suddenly become an issue with your installation (is this on an upgraded Operating System maybe?). Anyway, the answers to this Stack Overflow question give some good background information: https://stackoverflow.com/questions/6744437/windows-integrated-ntlm-authentication-vs-windows-integrated-kerberos/6744502

2

It seems you are missing the additional configurations required for HTTPS setup on CMS. Please go through the document here and make sure you have followed all the configurations as needed.

http://sdllivecontent.sdl.com/LiveContent/content/en-US/SDL%20Tridion%20full%20documentation-v1/GUID-FA3AF8BD-D49B-42FE-A33B-44A83E42CC9C

  • Thanks Ram. I have done the settings as explained in the topic. However the issue is still there. getting this error still /WebUI/Models/TCM54/Services/General.svc/GetUserSettings failed to execute. STATUS (500): System.ServiceModel.ServiceActivationException – Jey Feb 28 '14 at 14:56
  • Check in IIS if the authentication settings are propagated to lower folders. You can start with the folder structure that you see the error ..WebUI/Models/TCM54/Services/General.svc. – Ram G Mar 3 '14 at 23:18
2

Your User with which is you are trying log in have read/write (as applicable) permission on all Tridion related directories including Temp folders and web folder of tridion directory etc. and also verify weather you are using Integrated Mode in IIS. Also performe the steps explained in support.microsoft.com/kb/896861 (Method 1 -- adding hostname to NTML).

2

We had a similar issue. The providers for the Windows authentication needed to have Negotiate and NTLM. Under the main Tridion site > Authentication > Windows Authentication > Right Click Providers > make sure the Enabled Providers list Ntlm and Negotiate. Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.