3

We have upgraded system to 2013 SP1. We see all old publications under Content Management, but we try to navigation the items underneath, we get following error:

The socket connection was aborted. This could be caused by an error processing your message or a receive timeout being exceeded by the remote host, or an underlying network resource issue. Local socket timeout was '00:10:00'.
The read operation failed, see inner exception.

Server stack trace: 
    at System.ServiceModel.Channels.StreamConnection.Read(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout) 
    at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.SendPreamble(IConnection connection, ArraySegment`1 preamble, TimeoutHelper& timeoutHelper) 
    at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.DuplexConnectionPoolHelper.AcceptPooledConnection(IConnection connection, TimeoutHelper& timeoutHelper) 
    at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout) 
    at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout) 
    at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout) 
    at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout) 
    at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout) 
    at System.ServiceModel.Channels.ServiceChannel.CallOnceManager.CallOnce(TimeSpan timeout, CallOnceManager cascade) 
    at System.ServiceModel.Channels.ServiceChannel.EnsureOpened(TimeSpan timeout) 
    at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) 
    at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation) 
    at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message) 

Exception rethrown at [0]: 
    at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) 
    at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) 
    at Tridion.ExternalContentLibrary.Service.Client.ISessionAwareEclService.Impersonate(String userName) 
    at Tridion.ExternalContentLibrary.UI.DataExtenders.EclDataExtenderBase.GetEclServiceClient(PipelineContext pipelineContext) 
    at Tridion.ExternalContentLibrary.UI.DataExtenders.EclGetListExtender.OnProcessRequest(String command, String id, PipelineContext pipelineContext) 
    at Tridion.ExternalContentLibrary.UI.DataExtenders.GetListExtenderBase.ProcessRequest(XmlTextReader reader, PipelineContext context) 
    at Tridion.Web.UI.Core.Extensibility.Pipeline.<>c__DisplayClass1.<ProcessRequest>b__0(DataExtender extender) 
    at System.Collections.Generic.List`1.ForEach(Action`1 action) 
    at Tridion.Web.UI.Core.Extensibility.DataExtenderParameterInspector.BeforeCall(String operationName, Object[] inputs) 
    at Tridion.Web.UI.Core.Extensibility.DataExtenderOperationInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs) 
    at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc) 
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc) 
    at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage31(MessageRpc& rpc) 
    at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)

More over we already tried following:

<session transactionTimeout="3600" />

on %Tridion_HOME%\config\Tridion.ContentManager.config and

<system.transactions>
     <defaultSettings timeout="01:30:00"/>
     <machineSettings maxTimeout="01:30:00" />
</system.transactions>

In %windir%\Microsoft.NET\Framework64\v4.0.30319\Config\machine.config and %windir%\Microsoft.NET\Framework\v4.0.30319\Config\machine.config

Should we reach out to customer support? Suggestions are appreciated!

1

Disabling the loopback check in Registry helped to solve the issue.

May be out domain hostname was not upto standards expected. So needed this bit loopback check in Registry to make false and it worked this time.

  • Please can you add the details of what you did, so that this answer can be useful to others? – Dominic Cronin Mar 10 '14 at 6:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.