1

We have recently upgraded from SDL Tridion 2011 SP1 to SDL Tridion 2013 SP1. Everything seems to be working fine except creating/opening mailings. When trying to create a mailing we are getting the following error:

Could not load file or assembly 'Tridion.OutboundEmail.Templating, Version=2.2.0.742, Culture=neutral, PublicKeyToken=ddfc895746e5ee6b' or one of its dependencies. The system cannot find the file specified. Do you want to close this window?

We are using Oracle 11g R2 (11.2.0.4) as the CMS DB and Oracle 12c (12.1.0.1) client on the CMS server.

  • That seems like an outdated or missing dll. Did you follow all of the upgrade instructions? :-) – Alvin Reyes Aug 30 '14 at 15:45
  • @AlvinReyes I followed all upgrade instructions as per the online docs. Any ideas on how to solve this? – Husain Zahid Aug 30 '14 at 16:08
  • Maybe reload the default Template Building Blocks (though I'm not sure if they're related to creating a mailing?). I'd probably also start a ticket to be sure, maybe the upgrade missed that file. – Alvin Reyes Aug 30 '14 at 16:28
0

Opening a Mailing will render the associated Page. It looks like that fails due to a reference to an old version of the OE templates.

You might have forgotten to update the default TBBs that are used. Open Template Builder and use the Tools | Create Default Building Blocks option to update the default TBBs (which includes the Outbound E-mail ones).

If that still doesn't work, try to get the Page ID from the event log and open its template to see what is going on. Maybe it refers to an old copy of the TBBs or something.

  • Thank you for pointing out the outdated TBBs. Updating the TBBs solved the problem. – Husain Zahid Sep 2 '14 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.