5

I am getting the below error while setting up a DXA web site and browsing it.

No valid localizations are active for this site. Check the site log, and that you have the right localization IDs configured in cd_dynamic_conf.xml

I've checked the "cd_dynamic_conf.xml" and it has proper configuration.Also the logs don't suggest anything related. As answered here the same question, My binaries are set to publish to the Broker Database and are available in broker but I am still having the issue.

  • how are you accessing the site? localhost? the hostname and port need to match in the cd_dynamic_conf.xml file. Also the publication id. Did you publish the settings too? – Jaime Santos Alcón Jun 26 '15 at 18:51
  • Yeah, I've checked all the things you mentioned and published the settings. – Saurabh Gangwar Jun 26 '15 at 18:58
  • Have you checked the logs? What do they say? – Jaime Santos Alcón Jun 26 '15 at 19:05
9

With the help of Harald, I figured out the issue.

So when your DXA Web Application starts and the first Web Request is made, DXA creates a Directory called "BinaryData" in the root of you application to hold the binaries used on the page.

So to create it, your Website Application Pool's Identity User Account (in my case Network Service) must have write permissions on Websites Root Folder. I was missing those permissions on the Root Folder of my Website, assigning the right permissions solves the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.