2

We have integrated smart target module to one of client. Now we have a issue with fredhopper indexer is not sync with query server.

SDL Version: SDL Tridion 2013 SP1

Smart target version: 2014 SP1

Fredhopper version: fredhopper-7.5-revision-15

Topology.txt
# instance name | host | preset | indexer |  comment
indexer|localhost|1|-|Indexer for staging environment

query|localhost|2|indexer|Query server for staging environment

Issue:

We have found discrepancies between the Indexer and the query server. Meaning, the banner DCP component is successfully published and indexed but is not synced with the query server.

Indexer URL: http://localhost:8180/preview/?fh_location=//catalog01/en_US&preview_seo=false

Total : 383 Items

Searched by published banner dcp component item id : 198118

Results by pass ID (3) :

3 Items: Matched items displayed correctly

Query URL: http://localhost:9180/preview/?fh_location=//catalog01/en_US&

Total : 383 Items

Searched by published banner dcp component item id : 198118

Results by pass ID (3) :

3 Items: Matched but not displayed items in the search area

Kindly advise us to resolve this issue.

  • I don't see the discrepancy in your numbers. Did you paste correctly? – Nickoli Roussakov Apr 29 '16 at 13:13
  • Counts are coming correctly but the issue was indexed xml are not synced with qserver. when we search by particular item id on query server in the search results not coming that item.. – Velmurugan May 2 '16 at 10:10
3

It looks like indeed parts of the index are not synced properly.

Probably your best course of action: start with the log files from the "query" instance (fredhopper.log and syncclient.log), and then correlate the events in those with the "indexer" instance (syncserver.log, searchindexer.log, treebuilder.catalog01.log, xmlloader.log).

Also verify that all of these processes are actually running.

  • 1
    This issue seems to something wrong on fredhopper, we raised the ticket with SDL support, issue under investigation. If you run the manual re-index command bin\fresh-index-to-live indexer then it's getting sync.. seems to be some bug on fredhopper itemstore... will update you once SDL come back with solutions – Velmurugan May 5 '16 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.