5

i am using tridion 2013 sp1 with smarttarget 2014 sp1 and fredhopper 7.5 on windows machine on premise. my CD and fredhopper instance are running on same machine.

i am getting blow error while publishing component. i have done some changes in deployer confing for smarttarget and jar files. using this link

http://docs.sdl.com/LiveContent/content/en-US/SDL_SmartTarget_2014_SP1-v1/GUID-28D61030-27C1-4F1F-9117-A32E9F8FE16D

error while commiting deployment : failed during post transaction uploading zip to Fredhopper due to: 401 Authorization Required

 2016-06-01 18:15:57,162 ERROR HostedEnvironmentDeployer - Error uploading zip to Fredhopper due to: 401 Authorization Required
2016-06-01 18:15:57,163 WARN  CommitPhase - Failure during the post-transaction and the transaction will NOT be rolled-back
2016-06-01 18:15:57,163 WARN  CommitPhase - Failure during the post-transaction and the transaction will NOT be rolled-back
2016-06-01 18:15:57,183 ERROR DeployPipelineExecutor - Unable to execute onSuccess event in phase: Deployment Commit Phase for transaction: tcm:0-14049-66560
2016-06-01 18:15:57,183 ERROR DeployPipelineExecutor - Unable to execute onSuccess event in phase: Deployment Commit Phase for transaction: tcm:0-14049-66560
2016-06-01 18:15:57,183 ERROR DeployPipelineExecutor - Original stacktrace for transaction: tcm:0-14049-66560
com.tridion.deployer.ProcessingException: Error uploading zip to Fredhopper due to: 401 Authorization Required
    at com.tridion.smarttarget.deployer.fredhopper.HostedEnvironmentDeployer.uploadFile(HostedEnvironmentDeployer.java:290) ~[smarttarget_core.jar:na]
    at com.tridion.smarttarget.deployer.fredhopper.HostedEnvironmentDeployer.deploy(HostedEnvironmentDeployer.java:39) ~[smarttarget_core.jar:na]
    at com.tridion.smarttarget.utils.SmartTargetXMLUtils.persistFredhopperXML(SmartTargetXMLUtils.java:189) ~[smarttarget_core.jar:na]
    at com.tridion.smarttarget.deployer.FredhopperOutputBuilder.persistFredhopperXML(FredhopperOutputBuilder.java:119) ~[smarttarget_core.jar:na]
    at com.tridion.smarttarget.deployer.FredhopperDeployerModule.process(FredhopperDeployerModule.java:76) ~[smarttarget_core.jar:na]
    at com.tridion.deployer.Processor.process(Processor.java:109) ~[cd_deployer.jar:na]
    at com.tridion.deployer.workers.ProcessorWorker.doWork(ProcessorWorker.java:77) ~[cd_deployer.jar:na]
    at com.tridion.deployer.phases.CommitPhase.onSuccess(CommitPhase.java:116) ~[cd_deployer.jar:na]
    at com.tridion.deployer.phases.DeployPipelineExecutor.runSafeEvent(DeployPipelineExecutor.java:240) [cd_deployer.jar:na]
    at com.tridion.deployer.phases.DeployPipelineExecutor.doExecute(DeployPipelineExecutor.java:101) [cd_deployer.jar:na]
    at com.tridion.deployer.phases.DeployPipelineExecutor.execute(DeployPipelineExecutor.java:64) [cd_deployer.jar:na]
    at com.tridion.deployer.TransactionManager.handleDeployPackage(TransactionManager.java:82) [cd_deployer.jar:na]
    at com.tridion.deployer.queue.QueueLocationHandler$1.run(QueueLocationHandler.java:180) [cd_deployer.jar:na]
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [na:1.7.0_75]
    at java.util.concurrent.FutureTask.run(Unknown Source) [na:1.7.0_75]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [na:1.7.0_75]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [na:1.7.0_75]
    at java.lang.Thread.run(Unknown Source) [na:1.7.0_75]
  • Sounds like deployer doesnt have access to place the file at Fredhopper location "C:\fredhopper\<Indexer>\data\fas-xml-incremental\catalog01"! Could you check this. – ARRX Jun 1 '16 at 14:17
4

Check following things in your smarttarget_conf.xml:

  1. Deployer does have access to place the file at Fredhopper location which would be something similar to "C:\fredhopper\Indexer\data\fas-xml-incremental\catalog01" (should be defined at IndexeServer=>Deployment=>Location of your smarttarget_conf.xml on your deployer)

  2. The error stack shows that deployer is trying to deploy on hosted environment. If you are not using hosted Fredhopper environment, make sure Hosted=>Enable is set to false.

  3. Make sure you have provided correct authentication data for Indexer and qserver

Hope this helps!

  • Hi thanks for you reply it helps me by mistake i have set Hosted=>Enable to true now after setting it false it works fine. – meyank Jun 2 '16 at 6:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.