4

I have changed the site mapping for localized sites using Set-TtmMapping -RelativeUrl see my other question and re-published the pages and now site are working http://dxa.com/en the only issue which I'm facing now is CSS and JS are not loading. All the assets are available in file-system not published from CMS.

I have tried with @WebRequestContext.Localization and with other ways as well but no luck

Any suggestion would be highly appreciated

1

If you have changed the URL path of your Publication (Mapping), you will have to ensure you republish the entire Publication.

  • i've re-published entire SG and after that when i hit http://dxa.com/css/style.css this give me no matching localization found error and when http://dxa.com/en/css/style.css its return 404 Page. CSS path which is creating on view is /css/style.css. Please suggest – Hem Kant Oct 10 '16 at 7:28
  • Check the BINARY_VARIANTS table in your CD Content Store. – Rick Pannekoek Oct 10 '16 at 17:19
  • i have checked the BINARYVARIANTS table and all the URL now have /en as prefix is there anything i'm missing and that needs to check. – Hem Kant Oct 12 '16 at 11:44
  • Is the URL path really /en/css/style.css? DXA assumes that so-called Static Content Items have /assets/ in their URL. For example: /en/assets/css/style.css. Such URLs are handled by the StaticContentModule instead of the PageController. – Rick Pannekoek Oct 12 '16 at 17:20
  • We are not publishing the CSS/JS files from Tridion . CSS and JS files are available on file-system in root which is working before i created relative URL /en – Hem Kant Oct 12 '16 at 17:24
0

I have faced the same problem previously, here are the steps that I have followed to resolve the issue

  1. Publish Structure Information of the master site publication.
  2. Publish Structure Information of the localized site publication.
  3. Publish the Publish Settings page from both the publication and try.

Note: This is just a work around not a solution.

Hope it will help you to resolve the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.