3

Initially I had error in my "Update preview" in XPM :"Unable to preview the page. There is no publication target defined for this XPM enabled website. Contact your SDL Tridion administrator." this error got resolved now but I am getting another error:"Authorization failed. Please make sure the proper username and password have been configured in the Publication Target" every time I try to save or click on "Update preview" .I am using the same credentials everywhere. Changes are getting saved to CMS as well.

| improve this question | | | | |
5

Another cause of error "Unable to preview the page. There is no publication target defined for this XPM enabled website. Contact your SDL Tridion administrator." in "Update preview" XPM 2013 SP1: URLs in "Website URL's" are case-sensitive.

Check in the Publication Target (for that XPM-enabled site) on Session Preview tab that Website URL's list contains URLs in lowercase format.

I've got the issue ""Unable to preview the page. There is no publication target defined for this XPM enabled website. Contact your SDL Tridion administrator."" because URL in Website URL's for XPM Publication target was in uppercase "http://TESTCMS.com:82" and it was fixed by changing it to lowercase "http://testcms.com:82"

| improve this answer | | | | |
  • Our issue was similar, except that the default port 80 (or 443) needed to be left of the Publication Target Session Preview Website URLs List entry as IIS was dropping it. The call for GetPublicationTargetFromUrl must be exact. – Trevor Bartlett Jun 9 '14 at 18:03
4

We typically see this when the Publication Target isn't set up correctly (the error messages are spot on in those cases). Your Publication Target (for that XPM-enabled site) has Session Preview settings in the Session Preview tab for:

  • Content Delivery Endpoint URL, and if using a secure XPM Web service:
  • OData Access Token URL (with User Name and Password)
  • Web site URLs (your staging website)

The URL mentioned is the CD session preview Web service whereas the Web site URLs are for the site you're browsing in XPM.

Be sure to set these correctly, referencing your cd_webservice_conf.xml for the User Name and Password if needed, which are most likely different than your other credentials (at least they probably should be).

| improve this answer | | | | |
  • Thanks Alvin, I checked all the points. my OData service was not accessible hence was getting the error. I got it resolved. – user918 May 2 '14 at 17:04
  • hi Alvin OData Access Token URL (with User Name and Password) is required? from online manual, only secured OData Access Token URL need username and password – Lucas Liu Sep 10 '14 at 13:45
  • I believe you're right -- in one of the training setups, we just have the CD Endpoint URL as http://{preview-url}/odata.svc and the staging urls, but not Access Token URL details (and Session Preview works). – Alvin Reyes Sep 11 '14 at 3:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.