2

When we try to update preview on our production site using XPM in IE (9), we always the following javascript error: Access is denied. in the IE script console. The error comes from Content_v7.1.0.66.11_.aspx, Line: 38, Column: 312, which refers to var a=window.parent.frames["cookie_cleaner"]. In Chrome and FF there is no issue, also on acc there is no problem.

We executed a database copy and changed the publisher targets and page template to point to the correct servers, so there should be no differences.

We are using Tridion 2013 SP1. The preview site is on the domain http://preview.domain.com/ and Tridion runs on http://tridion.domain.com/, on ACC it is http://preview.acc.domain.com/ and http://tridion.acc.domain.com/.

Has anybody had this problem before and found a solution?

2

You should make sure you have a file named "se_blank.html" on your website, as explained on this documentation page: Preventing 404 errors on your staging Web site.

My guess is that you do not have this file and IE is showing "friendly HTTP errors" - thus loading a URL which is not in the same domain as your site. Which in turn causes the permission error when attempting to access the frame (technically a cross-site request which should not be allowed).

| improve this answer | |
  • Thanks for you suggestion, but this already crossed my mind. I see IE loading the se_blank.html file, but it still throws the error. – MrSnowflake May 22 '14 at 10:09
  • Interesting. Is the se_blank.html file and the code that's accessing the frame in the same domain? – Peter Kjaer May 22 '14 at 10:14
  • Also, have you checked the response from se_blank.html to see if the web server returns the right content (i.e. it's returning a 200 status and it's the content that you put in the file)? – Peter Kjaer May 22 '14 at 10:15
  • I triple checked se_blank.html and it comes from the same domain, has the correct content and gives 200 (or 304 when appropriate). – MrSnowflake May 22 '14 at 11:19
  • In that case I really don't know why Internet Explorer would prevent it. Perhaps check that you have the correct browser settings, as listed in the documentation? That's all I have at the moment, sorry :) – Peter Kjaer May 22 '14 at 11:51
-3

Apparently there was an issue with our HTML. Not sure what, as one of my colleagues fixed it.

| improve this answer | |
  • 2
    could you just give some more details what was issue & fix, could be helpful for people visiting this post in future – Raj Kumar Jun 20 '14 at 7:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.