6

On some pages this error occurs:

This is the error I get

Also it happens when you press finish editting.

There is no error in the event log on the Tridion CME, no entry in the event log on the presentation machine. There is no error in any of the tridion log files or application log.

I've checked the logs on the CME, the logs for the odata service, the website, the deployer, everything...

I've quadruple checked the configurations on all applications. Everything looks fine.

It is a website running on DD4T with Tridion 2013 sp1. Everything is published and retrieved from the broker. Binaries as well. No static file are being published.

It looks like the ambient data http module is generating this error, but is not reporting it.

Has anybody seen this error before? Or does anybody have a clue what is going on here?

  • Which Json reference are you using in your web application – user219 Sep 12 '14 at 20:21
  • Internal server error is usually thrown by odata service. – Raj Kumar Sep 14 '14 at 12:26
  • Jarno, I'm using the latest newtonsoft nuget package. – Thijs Sep 15 '14 at 17:06
  • Raj, the logs don't show any errors on the odata service. If you know what it could be, please tell me. – Thijs Sep 15 '14 at 17:07
3

Thanks to Albert Romkes who helped me out with this issue.

It was an inconsistency on the preview database name between development and the other environments. On Dev it was called Tridion_Broker_Session, on the other environments it was called Tridion_Broker_Preview. So updated those configurations. Then I forgot to update my cd_dynamic_conf.xml to reflect the correct domain names and publication id's.

This fixed my problem.

0

If the error is coming from the http module, the errors are (should be) either in the IIS logs or in the cd_core.log specified in the logback.xml from your tridion configuration - not in the OData webservice where you might expect it.

If it isn't, you should consider setting loglevel to DEBUG in the logback.xml ... and if its still empty, I'd call in support.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.