2

I am getting proxy related errors in the SmartTarget (2014 SP1) GUI. If I connect to the SmartTarget web service in a browser on the CMS server, I get the same error. If I turn off the proxy in the browser it connects OK. I don't see any mention of being able to control proxy settings in the SmartTarget docs.

Is it possible to stop SmartTarget using a proxy (or indeed to configure the proxy it uses, rather than have it pick it up automatically from the server settings)?

  • I have the same problem, only with the Session Preview service. I can configure a Content Delivery Endpoint URL, but no proxy settings. As a result, the CM uses the default proxy settings on my machine rather than connect to the OData service directly. – Quirijn Nov 25 '14 at 13:02
  • On Windows Tridion indeed picks up the proxy settings for the user it is running in. For system users running on a server that is fine but on you local developer machine that can raise this issue. For local development: why not disable the system proxy and set the proxy in the brower (works for Chrome and FF). – Jan H Nov 25 '14 at 15:12
1

You can control the proxy that gets used by a web application from the applicable web.config file; see this MSDN post on how that is done.

You can of course also configure the system proxy through IE; it should normally be correctly configured anyway or other process on the server might also not work...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.