6

I'm trying to install the recently released PublicationMapping extension to work with TopologyManager on Web 8 https://community.sdl.com/developers/tridion_developer/m/mediagallery/1309

After performing all the steps as mentioned in the distribution documentation, the CME refuses to load (stuck in Loading) and I get see the following error in console :

Uncaught SyntaxError: Unexpected token <

I would associate this with perhaps a typo in the configuration and invalid XML but I double checked the snippets that I added to System.config and they are valid xml items.

The interesting bit is that if I comment out the Model entries, the CME loads just fine.

Note that, it's a vanilla installation of Web 8 and there are no publications defined yet, would that be a problem?

-Kunal

  • 1
    I probed the extension and it works perfectly. Have you tried to create a publication to see if it solves the problem?. It seems an issue with some xml configuration text. If you have copy/pasted from the doc, maybe a hidden character is causing the fault. I use to type all the configuration to avoid these problems. Have you increased the "modification" value to avoid cache? – Raúl Escudero Feb 20 '16 at 18:17
  • I'll try creating a publication and see if help resolve the problem. Thank you for your inputs Raul – Kunal Feb 20 '16 at 23:07
5

Mea Culpa! The problem was missing a virtual directory for the Model which explains the problem solving itself when commenting the model section of the extension.

But I do wish that the errors showing up in CME would be a bit less cryptic.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.