1

When I tried to install Tridion Sites 9.1, an error "The RPC server is unavailable" occured. Following error is shown in a log file.

[06C0:0860][2020-05-11T17:02:12]i000: CurrentPackageId=TopologyManager 
[06C0:0860][2020-05-11T17:02:12]i000: ErrorPackageId=_TopologyManager 
[08F8:0A88][2020-05-11T17:02:12]i301: Applying execute package: TopologyManager, action: Install, 
    path: C:\ProgramData\Package Cache\{BBA9F41C-816A-467A-B93F-67BDBB0FCC7B}v9.1.1966\TopologyManager.msi,
    arguments: 'ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7" 
        TRIDIONHOME="D:\Program Files (x86)\SDL\Tridion Sites" DB_SERVER="dbname.ap-northeast-1.rds.amazonaws.com" DB_TYPE="MSSQL" 
        DB_NAME="Tridion_Topology" DB_INTEGRATED="False" DB_USER="TTMDBUser" DB_PASSWORD="*****" 
        WEB_ID="3" WEB_DESCRIPTION="Tridion Sites Topology Manager" WEB_IP="(All Unassigned)" WEB_PORT="81"
        WEB_HEADER="" ROU_NAME="severname\Topology Manager Users" 
        ROS_NAME="severname\Topology Manager Service Users" 
        ADMINS_NAME="severname\Topology Manager Administrators" SYSTEM_ACCOUNT_NAME="MTSUser"
        SYSTEM_ACCOUNT_DOMAIN="GWEB-LIVE" SYSTEM_ACCOUNT_PASSWORD="*****"
        TRIDION_CM_ENVIRONMENT_ID="cmenvironmentid" WEBSITE_ROOT_URL="http://severname.net:80"
        AUTHENTICATION_TYPE="Windows" CORE_SERVICE_ROOT_URL="net.tcp://localhost:2660"
        ADDLOCAL="FeatureTopologyManager"' 
[06C0:0860][2020-05-11T17:02:22]i000: The RPC server is unavailable    

An similar issue is found in following page. https://gateway.sdl.com/apex/communityknowledge?articleName=000012332

My environment is on AWS and the CMS server is belonging to AD domain, but didn't remove host name from AD and added new host with same hostname as removed one as above page mentions.

Fire Wall is enabled on the CMS server, but outbound and inbound is all allowed, excepting some specific IP is blocked on outbound rule.

Also I'm upgrading SDL Web 8.1 to Tridion Sites 9.1, so upgraded DBs and newly installing Sites 9.1 on another server.

I ran installer by "Run as Administrator".

What did kind of RPC call fail? Does anyone know similar issue?

UPDATE

I found following error.

Calling custom action CommonCustomActions!CommonCustomActions.WindowsGroupCustomActions.CreateGroupExecute
Begin CreateGroupExecute
CreateGroup: Unable to find the group 'GWA_DEV_BO_124\Topology Manager Users'. Creating new...
CreateGroup: Unable to find the group 'GWA_DEV_BO_124\Topology Manager Service Users'. Creating new...
CreateGroup: Unable to find the group 'GWA_DEV_BO_124\Topology Manager Administrators'. Creating new...
CreateGroupExecute: error The RPC server is unavailable  

   場所 System.DirectoryServices.DirectoryEntries.Find(String name, String schemaClassName)
   場所 CommonCustomActions.WindowsGroupCustomActions.CreateGroup(Session session)
   場所 CommonCustomActions.WindowsGroupCustomActions.CreateGroupExecute(Session session)
MSI (s) (A0!28) [16:55:01:058]: Product: Tridion Sites Topology Manager -- The RPC server is unavailable  

This is same issue as described in following page. https://gateway.sdl.com/CommunityKnowledge?articleName=000009538

When login by local administrator user to CMS server, installation succeeded, but I need to install Sites9.1 by a different user. The CMS server is belonged to a domain, and the user who should install Sites9.1 is made on the domain, and the user belonged to local Administrators group. Why the user cannot install Sites9.1 even though it is belonged to Administrators group?

Update It turns out that the cause of this error is that AD server's machine name cannot be resolved from CMS server. It is solved by configuring to let resolving AD server's machine name.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.