9

I am configuring Fredhopper (fredhopper-7.5-revision-15) as per the instruction mentioned on SDL live content manual for SmartTarget 2014. After executing on the command when I am browsing http://localhost:8180/fredhopper/admin/ am getting the below view with error message Please wait The Business Manager will be available when the indices are loaded..

fredhopper/Admin

Here the GUI is supposed to ask the login credentials. I have also followed the steps mentioned on the Fredhopper site but no luck same response

Also, I have installed SmartTarget on Tridion 2013 SP1, I am getting the targeting option but unable to add a promotion.

  • I reformatted question and added error message in text for SEO. – Jan H Jan 21 '15 at 13:33
6

You will get the Please wait The Business Manager will be available when the indices are loaded. message as long as Fredhopper indices are not built. You could say, the problem is that the Fredhopper system has no data.

To initialize Fredhopper you can either

  • Copy the SmartTarget 2014\Fredhopper extensions\data\metadata.xml file from the installation media to the <BASE_DIRECTORY>\<INDEXER>\data\fas-xml-incremental\<CATALOG01> folder in Fredhoppper. See step 10/11 in the Quick Guide and step 7 in the Installing SmartTarget on premise section.
  • Publish a SmartTarget enabled component presentation. That is a dynamic component presentation published with a component template, which has the Add to SmartTarget template building block.
2

Run below command to get your fredHopper up and running. Assuming you fredhopper installation is in e:\fredhopper and assuming your Index Server name is SmartTarget you commadn will be.

bin\run-etl-job STJob.kjb "-DINSTANCE=SmartTarget" "-DTRIGGER=load-data" "-DUNIVERSE=catalog01" "-DEXECUTIONPATH=E:\fredhopper\data\instances\SmartTarget\custom\"

before calling this command do follow below step

Copy the SmartTarget 2014\Fredhopper extensions\data\metadata.xml file from the installation media to the \\data\fas-xml-incremental\

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.